Hinweis: Fehler SHCTypeDeviceInclusion.RWE nach der SHC 2.0 Migration / Updates

  • Hallo ;)


    Solltest Du zu den Personen gehören, die diese Fehlermeldung "SHCTypeDeviceInclusion.RWE" nach einem Update erhalten, so hast Du 100%-ig eine Migration von der 1 Gen Zentrale (SHC 1.0) zu Gen 2 Zentrale (SHC 2.0) hinter sich.


    Dieser Fehler tritt immer dann auf, wenn der User mit einer SHC 1.0 Geräteerweiterung auf die SHC 2.0 wechselt. Dabei wird das Plugin (SHCTypeDeviceInclusion.RWE) mit in die SHC 2.0 Konfiguration aufgenommen und verursacht Fehler. Da die SHC 2.0 keine Geräteerweiterung mehr benötigt, so wirft sie diesen Fehler aus.


    Dadurch bekommst Du nach jedem SHC Update eine Fehlermeldung und Deine CPU (Prozessor der Zentrale) könnte dadurch überhitzen (zumindest ist das gerade bei mir der Fall). Ob es bei alle betroffenen Personen passieren kann, kann ich z.Z nicht bestätigen. Habe dazu den technischen Support bemüht und werde Dir weitere Infos mitteilen, sobald ich mehr weiß.


    Hier ein paar Infos.

    • Meine CPU lag bei 30-100% (laut einiger User sind 1-5% OK)
    • Nach dem Updates teilweise bis zu 100%
    • Dadurch könnte die CPU dauerhaft überhitzen
    • Erst ein Neustart brachte Abhilfe., dann wieder bei ca. 30%

    Solltest Du diese Fehlermeldungen erhalten, schreib bitte eine Email an smarthome.service@livisi.de mit der Bitte, den alten RWE Plugin "SHCTypeDeviceInclusion.RWE" zu entfernen (so verschwinden die Fehlermeldungen). Wichtig:

    • Dein Name
    • Livisi Account Name (zum einloggen)
    • Deine SHC 2.0 Seriennummer

    Zu finden auf der Rückseite der Zentrale oberhalb des Codes / SN oder unter Einstellungen (APP). Du kannst gerne hier in diesem Beitrag Infos zu Deiner CPU mit uns teilen.


    Lg Tom


  • Ja, das wird durch ein altes SHC1.0-Plugin verursacht, mit dem die neue Zentrale nichts anfangen kann. Allerdings wird lediglich diese Fehlermeldung geworfen und dann dieses Plugin ignoriert. Eine Beeinträchtigung im Betrieb gibt es dadurch nicht. Eine höhere CPU-Last oder gar eine CPU-Erhitzung hat andere Ursachen.

    Falls der neue Support durch die Bitte, das alte Plugin zu entfernen, überfordert sein sollte: Mein Angebot (ich erkläre es ihnen gegen Entrichtung einer angemessenen Gebühr) steht :) :)

  • Wie Michael schon geschrieben hat, glaube ich ebenfalls, dass die Prozessorlast bei Dir eher von irgend einem Szenario-Ping-Pong kommt.


    Ich würde mal langsam und zielstrebig die Liste der Szenarien durchklicken und eventuelle Kandidaten deaktivieren. Oder Du deaktivierst eines nach dem anderen, bis die Last unten ist.....


    Leider aktualisiert sich die Last nur alle 10 Minuten...

    Das ist doch ein Prima-Job für einen Sonntag-Nachmittag...... ;)


    Gruß Ralph

  • Mache nichts anderes seit Gestern Abend :D


    Lustig wurde es nur, als ich feststellte, dass ich 2 Heizkörper-Thermostate (RST) nicht über den Raum-Thermostat (WRT) steuern kann. 2 davon haben außerdem die Kindesicherung drin und wenn die Zentrale (SHC) defekt ist, kommst Du an die Einstellung der RSTs nicht ran. Also habe ich gerade eine durchschnittliche Raumtemperatur von muckelig-warmen 24,7°C in Haus ^^


    Hab die Zentrale doch noch irgendwie über Lan ans laufen bekommen (Wlan will sie nicht annehmen, sucht sich tot nach der Bluetooth Verbindung). Szenarien & Zustände & Pluugins wurden alle nach einander deaktiviert, trotzdem spinnt die CPU Last. Liegt wohl doch an dem RWE Erweiterungs-Plugin.

  • Das eingangs erwähnet Plugin "SHCtypedeviceinclusionRWE" hat definitv NICHTS mit jeglichen anderen Problemen oder Fehlermeldungen zu tun. Es ist lediglich ein Hinweis darauf, dass mit Deinem Account eine vormals limitierte SHC1.0 (Basic-5) Zentrale migriert wurde und die Erweiterungen für diese SHC1.0 Zentrale jetzt, beim ihrem Laden für die SHC2.0 Zentrale, keinen Sinn mehr ergeben.


    Solange niemand vom Support-Team diese unnützen App-Zuweisungen von Deinem Account entfernt, kannst Du Resets mit der Zentrale machen bis der "Arzt kommt" aber diese Apps werden trotzdem immer diese Meldungen auslösen.

  • Also, die Zetrale wird getauscht. Vorhin kam eine Email.

    Ich werde berichten, wenn die neue angekommen und konfiguriert ist.

    Nee, ne?
    Das ist ja Realsatire vom Feinsten.
    Wie Thomas schon gesagt hat - ob die Zentrale getauscht wird, oder ob in China ein Sack Reis umfällt ...
    Ich will ja nicht ausschließen, dass das Problem mit der Prozessorlast dadurch behoben wird (wenn die bisherige Zentrale einen Schuss in der Hardware hat), aber die DeviceInclusion-Meldung wird durch einen Zentralentausch nicht beeinflusst.

  • haha, Leute :D


    Die Zentrale ist hin, der Plugin bzw das dauernde "nachladen" des Plugins, hat die CPU überlastet, irgendwann hat gar nichts mehr funktioniert. Konnte noch nach und nach, alle Szenarien u Zustände deaktivieren, dann wieder resetet. Dann lief das Ding kurz, es kam wieder eine Update-Fehlermeldung (siehe oben) mit dem SHCTypeDeviceInclusion.RWE-Fehler und die CPU war wieder unter Volllast.


    Jetzt ist das Plugin durch den Support deaktiviert, eine neue Zentrale zu mir unterwegs und die alte Zentrale läuft mit wenig CPU Last...allerdings lässt sie sich jetzt nicht mehr per Wlan anbinden. Irgendwas ist jetzt mit dem Bluetooth passiert. Das Teil spinnt total, aber die CPU ist jetzt bei 1-2% nach dem deaktivieren des Plugins.

  • Was? Meine Vermutung, dass es nicht an der Hardware liegt?

    Ich denke, dass Thomas eher den Zusammenhang zwischen DeviceInclusion-Fehlermeldung und hoher CPU-Last meinte. Diesen Zusammenhang gibt es nicht.


    Aber es ist ja erfreulich, dass der neue Support tatsächlich in der Lage ist, den unnötigen Plugin-Eintrag zu entfernen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!