Posts by catdog79

    Ach cool 3D Drucker habe ich auch. Hab mir nur gedacht so wäre es sogar einfacher weil dann der Farbton und die Form perfekt ist. Würde den unteren Teil einfach leer räumen und ein Alu-Passivgehäuae für den Raspi einfach reinstellen. Eventuell noch ein kleiner 40er Lüfter dazu. Habe da noch 40er Noctua von den Hotends in der Bastelkiste, die sind so leise, dass die sogar im Wohnzimmer dauerhaft laufen können.;):D

    Hallo zusammen, suche eine defekte Smarthomecentrale 2.0.


    Die Elektronik darf defekt sein, das Gehäuse sollte aber noch in gutem Zustand sein.


    Würde 10Euro + Versand bezahlen.

    Habe da auch schon wieder die nächsten Fragen.


    1. Wenn man auf lokale SHC umgestellt hat, benötigt man ein neues Binding für die SHC, das ist aktuell ja gerade in Arbeit. Gibts da auch schon eine Testversion davon, oder steht hier die Entwicklung noch am Anfang?


    2. Wenn das neue Binding vorhanden ist und man auf local umgestellt hat, bekommen ja sowohl die SHC als auch Geräte neue UID´s. Am Anfang (also vor März 2024) kann man ja zwischen den beiden Modis (local/ online) noch hin und her schalten. Dabei wird dann wohl in OpenHab auch beide Varianten benötigt, oder? Also die jetztige für Onlinebetrieb und die neue für Offlinebetrieb?

    Kann man dann ja einfach 2 SD Karten verwenden (bei Verwendung von OH auf Raspberry), eine mit dem Image für Offline und eine mit dem Image für Onlinebetrieb, oder sehe ich das falsch?

    Genau das ist für die Sprachsteurrung. 😉😁


    Zuerst das machen was Tupper in seiner Anleitung hat, das funktioniert dann für alle Sachen wie Licht, Schalter, Steckdosen usw.


    Für die Thermostate dann so wie ich es hier beschrieben habe. Das ist aber nur der letzte Schritt, davor muss schon alles was in Tuppers Anleitung (auch das verlinkte Video) steht, erledigt sein.

    Ich werde auch nicht mit den files arbeiten sondern wieder die PaperUI verwenden.

    Das andere ist mir zu komplex und ich habe da auch ehrlich gesagt keine Lust mich da einzuarbeiten.

    Das Smarthome ist Mittel zum Zweck und nicht mein Hobby für die Freizeit.


    Ändert aber wohl nichts daran, dass er wahrscheinlich einfacher ist, das System zu gegebener Zeit neu aufzusetzen als in den ganzen json Dateien rumzufuhrwerken.


    Zumindest bin ich für mich jetzt zu dem Entschluss gekommen.


    Werde das jetzige OH aber bis zum "richtigen Umzug" noch als Teststation für verschiedene Sachen missbrauchen und dann irgendwann ein sauberen cut machen und das System neu aufsetzten.


    Werde hier in der Zwischenzeit trotzdem noch fleißig mitlesen und vielleicht auch noch die ein oder andere Frage stellen.


    :vulcan::thumbup:

    Ich pers. hab nicht die Zeit, es from the scratch neu zu machen... Immer nur mal 10Min hier, 10Min da... 🙈


    LG Manuel

    Vielleicht wäre es dann besser erst gar nicht weiter zu machen, sondern erst zu warten bis die neue Firmware rauskommt und dann den Umzug durchzuführen. Die Geräte laufen ja dann trotzdem erstmal weiter über die Livisi App, ebenfalls ist ja noch ein Parallelbetrieb von offline und online möglich, aber deine Geräte bekommen schon die neuen UID´s.

    Ob du jetzt die ganze Arbeit investierst oder erst in 6 Monaten ist doch egal. Aber das erspart dir unter Umständen sehr viel Ärger. Wenn es dumm läuft, musst nämlich sowieso alles neu machen, da irgendwo ein Fehler drin ist und man den ohne sehr großen Zeitaufwand nicht findet.


    Ich habe aktuell nur mit OH rumgespielt um zu wissen wie aufwändig das Ganze später ist und ob es auch funktioniert. Mein Ergebnis habe ich. Es geht und ist ca. 1 Wochenende arbeit. Klar hängt natürlich davon ab wie groß das System ist und was man alles über OH laufen lassen will, aber wie gesagt, ob du jetzt die Arbeit machst, oder in 6 Monaten, sollte doch egal sein. ;)

    Also bei Things stimme ich zu, da wird auf die UID verwiesen.

    (siehe auch Bild in Post 24 "org.openhab.core.thing.Thing.jason" Datei.


    In der Item Datei also "org.openhab.core.items.Item.json", wird nur auf den Namen referenziert, wenn man den Namen "Label" also wieder gleich vergibt, sollte man bei den Items nichts anpassen müssen. Gleiches gillt übrigens für die "org.openhab.core.items.Metadata.json" Datei, auch dort ist nur der Name "Label" referenziert.



    Vielleicht sehe ich das Ganze aber tatsächlich etwas zu naiv. Werde es einfach Testen und dann weis ich genaueres ob es funktioniert oder nicht.



    Nachtrag:

    In der Datei org.openhab.core.thing.link.ItemChannelLink.json sind auch die ganzen UID´s mit drin.


    Langsam komme ich zu dem Schluss, dass sich das Ganze nicht wirklich lohnt und man besser dran ist eine neue und saubere Installation durchzuführen. Zumindest bei denen, welche die Einrichtung über das PaperUI und nicht textbasiert gemacht haben.

    Schon alleine die Recherchen um bis zu dem Punkt zu kommen, haben so viel Zeit in Anspruch genommen, da hätte ich schon die hälfte einer Neuinstallation erledigt, :/

    Also ich habe mir schonmal die Mühe gemacht alle aktuellen UID´s in eine Excel zu überführen, macht es später einfacher die neuen UIDs per "suche und ersetzen" zu implementieren.


    In der Json Datei sind auch genau diese UID´s wieder zu finden.


    Bei mir sieht das wie folgt aus:

    "blau" unterlegt ist die Json Datei und Rechts nebendran meine Excel. Dort habe ich die Uid´s aus dem PaperUI eingefügt. Nicht wundern wenn die UID´s komisch aussehen, ich habe aus Datenschutzgründen Teile davon im Bild ausgeschnitten.


    Jetzt fehlt mir nur noch das Obergeschoss und der Keller, dann bin ich auf das Umstellen vorbereitet. Werde vielleicht mal zum Testen ein Heizkörperthermostat durch einen neuen austauschen und dann entsprechend die UID usw. austauschen. Wenn der Thermostat dann tut wie er soll, dann weiß ich, dass dies später ebenfalls passen sollte.

    Hab mir die Json Datei mal angeschaut, puh das ist auch ganz schön Fleißarbeit dort alle UID´s zu ändern.


    Wird aber wohl schneller gehen, als alles neu anzulegen.

    Denke werde das dann mal zuerst versuchen und nur im Notfall eine komplette Neuistallation durchführen.


    Habe schonmal die Json Datei auf dem PC in original gesichert, falls bei dem Versuch etwas schiefgeht. ;)

    Ok, danke für die Info.


    Eigentlich richtet man das ja nur einmal ein.

    Habe jetzt an meinen Einstellungen und Szenarien in der Livisi App auch schon seit 2 Jahren nichts mehr geändert.


    Wenn es mal läuft und so eingerichtet ist wie man will, muss man da ja nicht ständig ran.

    Von der SD Karte des Openhab Servers mache ich ein vollständiges Backup und kann dann die SD Karte jederzeit clonen.


    Für mich ist die Smarthomesache nur Smart, wenn ich dort nicht ständig Zeit reinhängen (Erstinstallation mal abgesehen) muss, dafür habe ich andere Hobbys.


    Das Openhab habe ich jetzt nur installiert, weil ich später weiterhin alles über Alexa (Sprachbefehle) steuern können will. HabPanel finde ich auch nicht schlecht, da man die Übersichtsseite so anpassen kann wie man will.


    Werde dann wohl warten bis die Firmware für Offlinebetrieb gut funktioniert und dann werde ich nochmal ein Wochenende investieren und alles nochmal in Openhab einrichten.

    Leider habe ich die ganzen Things nicht über Dateien konfiguriert, sondern die Things direkt über openhab eingebunden. Habe gerade im Standardordner von Openhab nachgeschaut, ob dort die Textfiles automatisch angelegt werden und man diese dann einfach editieren kann. Leider ist der Ordner bei mir leer.


    Ich denke mal ich bin im richtigen Ordner, oder:




    Also Things und Items ist bei mir leer.

    Werden über Openhab irgendwo anders noch txt.files angelegt, welche bearbeitet (UID) werden können?


    Direkt über Openhab kann ich die ID oder Identifier (UID) nämlich nicht mehr ändern.

    Daran habe ich bis jetzt gar nicht gedacht, dachte dass man nur die SHC neu Binden muss.


    Naja, hab ja jetzt Übung, muss man dann halt wohl oder übel nochmal alles anlegen.

    Da ich aktuell aber keine Regeln über OH laufen lasse, sondern nur die Alexafunktionalität und HabPanel (übersichtlichere Anzeige möglich) hält sich die Arbeit halbwegs in grenzen. Wird aber wohl trotzdem ein Wochenende dafür drauf gehen.

    An dem lag es nicht.

    Habe jetzt nochmal ein weilchen gespielt und die Lösung gefunden.


    Man muss den Ganzen Thermostat einfügen und nicht nur den Point Solltemperatur.

    Danach müssen die einzelnen Points ebenfalls mit Alexa verknüpft werden, dabei ist das System dann schon so klug, dass man dann nur noch sagen muss was die einzelnen Points im Thermostat machen.


    1. "Thermostat Gerät" mit Alexa verknüpfen:




    2. Aktuelle Temperatur mit Alexa verknüpfen:




    3. Luftfeuchtigkeit mit Alexa verknüpfen:



    4. Solltemperatur mit Alexa verknüpfen.



    Bei der Solltemperatur kann man unten angeben in welchem Regelbereich geregelt werden darf.

    da steht glaube ich default 4:32 was für 4°C - 32°C steht.

    Hier habe ich von 6:26 bei mir angepasst.

    Ich glaube da steht die Lösung drin, leider bin ich noch nicht so tief drin um das zu verstehen. Ich habe bis jetzt auch zur Steurung im HabPanel nur meine Gerätepoints angegeben. Alles andere wo man im Code umschreiben muss, ist bei mir noch ein Tuch mit sieben Siegeln. Hatte gehofft, dass ich da nicht ran muss. Hoffe jemand hier hat die Thermostate schon über Openhab mit Alexa verknüpft und kann das mal etwas genauer erklären.


    Bei den Dimmern, Steckdosen klappt das relativ einfach. Sowohl im HabPanel als auch Alexa. Thermostat bekomme ich im HabPanel ebenfalls hin, aber bei Alexa leider nicht.

    Hallo,


    ich bin noch neu und etwas unerfahren.

    Openhab habe ich mittlerweile auf einem Raspberry am laufen und auch schon mal soweit eingerichtet.

    Hab mich da an dem Thread von Tupper orientiert um die Alexa Funktionalität einzurichten.


    Habe jetzt auch schon viel mit OpenHab rumgespielt und auch schon Habpanel usw eingerichetet.

    Die Steuerung von meinen UP Dimmern, Steckdosen usw. funktioniert auch.


    Leider bekomme ich die Heizkörperthermostate nicht hin.

    Wird mir in Alexa angezeigt, Gerät reagiert nicht, bzw. Gerätefehler.


    Vermute mal, dass hier meine Einstellung der Metadaten nicht korrekt ist.

    Kann mir hier jemand weiterhelfen, was bei den Metadaten hinterlegt werden muss?


    Aktuell habe ich nur die "Solltemperatur" mit Alexa verknüpft, entgegen allen anderen Things, gibt es hier aber zusätzliche Einstellungen.


    Vielen Dank schonmal.